Channel Plus App will not open (not beta)

Glad it is not just me I have the same issue. Apps just starts to launch then exits. Everything else seems to work fine.
I will wait for v4.1.2 to show up and update the app.


My wife is pissed at me...she can only watch certain program via channel DVR.

I tried the Beta 4.13 and it does the same thing. I sideloaded it from my android phone.

Sorry folks. Usually Amazon will not push out builds that they detect are not working. This time they detected it wasn't working, but pushed it out anyway.

I'm working on a fix and will have a workaround shortly.

Okay we have a fix in the latest beta apk (v2022.01.19.2217)

To install it:

  1. Install Downloader app by AFTV news
  2. Enter 56136 in the url box

No change opens and closes immediately.

Does it show version ending in 2217 under Settings > Apps > Installed Apps > Channels DVR (Beta)

Yes it is 4.13-301192217

What device?

Testing here and its working with:

Amazon AFTT
FireTV 5.1.1 API/22

Amazon AFTRS
FireTV 5.1.1 API/22

And you're sure you're launching the beta app (with the square icon), not the stable build?

Confused because it is working here..

Worked for me thanks.
And yes for some reason it was hard to find the Beta app to launch but found the right one.

1 Like

I removed all the channel apps. Restarted. Used the downloader and install the one that downloaded. It looks different than what I'm used to seeing.

Mine is Amazon AFTRS yours is different.

Strange, different how? Maybe some settings are different and the tabs aren't the same?

But it is working now?

I meant the icon is different. I'm restart the FireTV now to see that will help. Purplish screen then to black ...not working.

I see, okay.

I only have the stick, not the element tv edition. But they are the same API22 and should work the same way.

Are you able to download the adb logs from the device? That will show me where the crash is happening and how to fix it.

I don't know how, I know the Ip address. What commands do I use to talk to the tv?

Do you have a pc or Mac?

Windows 10 desktop

I also tried the beta via the downloader, same problem as with the stable app. My FireTV box is 2nd gen, FireOS Looking into how to get adb logs now...