Commercial Skip on Fire TV Cube


#1

How do you use the commercial skip feature? I saw a posting in this list that said to double-click the right button on the remote. I assume this is a reference to the round directional control that encircles the select button. That doesn’t work on my FTV Cube. I can see in the timeline where the commercials are but, double pressing the right button just makes two 30 second skips, doesn’t matter how quickly or slowly I do it.


#2

Are you using the remote that came with the cube, or a different one?


#3

The one that came with the Cube.


#4

I just tested on the Cube and its working for me. It only works while you’re within a commercial (the dark parts on the timeline).

Can you try on a different recording?


#5

Hi Amam, I tried a few other recording as well as another remote from a fire tv stick. No luck. I do see the commercials on the timeline bar, and yes that is where I’m doing the double press on the right directional button. My app is version 2.02, is that the current version? I have verified i have the current FTV
Cube OS NS6222/1536.
Also wanted to ask how the testing was going on the stuttering problem on these devices.

Thanks


#6

What kind of stuttering problem are you having?


#7

Same as others have noted. Live and recording seem to drop frames. At times its every few seconds. Really makes it unwatchable. I have my Cube, DVR, and HDHomerun tuners on a dedicated switch. All are 100mb wired. If it matters my HDHomerun app, DVR, and Plex do not have this issue.


#8

I noticed the same thing on a new recording. If I’m within a commercial and double-tap the right button, it only skips forward 1 minute instead of skipping the commercials. It’s a brand new Cube and brand new install of Channels. Any ideas?


#9

These issues were fixed last week so I’m surprised it’s still happening.

Can you try with v2.0.3. If it still happens, Submit Diagnostics from the Player tab and post here when they finish uploading.

Then try turning off Surround Sound to see if it helps.


#10

Right now the code expects the two clicks will happen within 250 milliseconds. I’m going to try to increase it to 350ms to see if it helps detect the double click more reliably.


#11

Thanks for the quick reply. I’ll give that a shot!

Is it possible to set it to automatically skip commercials without having to double-tap the button? I’m a recent Media Center convert and that was a cool feature. You could then toggle the automatic skip on/off while you were watching the show in case comskip didn’t scan the file correctly.


#12

I Installed 2.03, but only had time to do a quick test. However, I pleased to report that seems to have resolved the stuttering! I tried live tv as well as a recording, each for about 10 minutes. With the previous version I would have experienced the issue in that time frame.

Thanks Aman!


#13

Well seems I still have some stuttering in version 2.03. Significantly less than before, but still there. I have submitted the Diagnostics. Another issue that cropped up with 2.03, I have one channel (2.1) that I can no longer tune to. Every time I do it starts to show it then tells me to check my HDHomerun tuner. All the other channels work fine, and I can tune to 2.1 using the HDHomerun app. If it helps, I get a lot of “[Media Library] Thumbnail generation failed: /share/CACHEDEV1_DATA/Multimedia/Channels/Streaming/ch2.1-dANY-ip192.xxx.xxx.xxx/stream6.ts” errors on the DVR when tuning to 2.1.


#14

Huh. Where do you see these messages?

First, you should tell whatever media library software that’s enabled to ignore that Streaming directory.

Second, it looks like your DVR is transcoding for some reason. It would be better if the app connected to the hdhomerun directly. Did you use “login to remote DVR” to connect? Is the Streaming Quality setting set to Original?


#15

Sorry for the confusion… The messages were from the QNAP NAS logfile which hosts the Channels DVR. The messages started when I upgraded tthe FTV Cube Channels app to 2.03. I suspect the ‘Media Library’ referenced in the messages was its own (QNAP) integrated library, so I have just now disabled it.
I do have the Streaming Quality set to Original in FTV app, and did not login to Remote DVR. Not sure here, but I think what you may have seen in the diagnostic was when I did some testing using the Web Player on a Windows 10 PC, which by the way can tune to all channels including channel 2.1, and does not have any stuttering.


#16

Okay thanks for the clarification.

There is a v2.0.4 update scheduled to released today which has a fix for the commercial skip remote press issue, as well as the failure to play some channels. It should be available this afternoon sometime.

In the mean time you can go to Player tab and turn off Surround Sound and then that channel should play as well.


#17

The new version just went live on the Amazon Store.


#18

Just picked up 2.04, and can confirm that commercial skip is working, and I can now tune to all channels.
Kudos to the you guys, very impressed with the quality and responsiveness of your support, Thank You!


#19

Great!

How is the stuttering issue?


#20

5 posts were split to a new topic: Audio crackling/popping on Fire TV Cube