Direct TV: Authn: 401 : Data not found

i've honestly never done that because i assumed the auto updates (or when i do it myself via the UI) were doing everything that needed to be done. is that not the case?

1 Like

When Aman updates the headless-chrome being pulled it's done by updating the docker container image.

1 Like

interesting, good to know. i'll try pulling the new image and see if that resolves it.

pulling the new image didn't fix it either. still the same 401 data not found error.

are you now on chrome v109?
You should be if you pulled and ran the latest fancybits/channels-dvr:tve

[TVE] action=version product=Chrome/109.0.5414.74 jsVersion= protocol=1.3 revision=@e7c5703604daa9cc128ccf5a5d3e993513758913

Did you the TVE Troubleshooting tips

yes, v109.

2023/08/21 18:40:30.781753 [TVE] action=version product=Chrome/109.0.5414.74 jsVersion= protocol=1.3 revision=@e7c5703604daa9cc128ccf5a5d3e993513758913

Troubleshooting steps to follow, like a checklist

  1. If you can't watch the network at their Live streaming website, nothing Channels can do. Like or check availability buttons at Channels Support - TV Everywhere Availability for your Provider

this seems irrelevant since i can't authorize any provider (not specific channels), but regardless yes i can see streams like TBS for example in the browser.

  1. Make sure your package or container (if running in one) is up to date.

we just did this.

  1. Update to the latest DVR prerelease version see this article for how

did this earlier.

  1. Run troubleshooting from the DVR web UI Support>Troubleshooting and make sure all green checkmarks. (If it says Chrome corrupted or not up to date it should offer a green fix button to press.)

all green.

  1. Make sure your chrome or headless chrome is up to date. (Current included version is 97 or 109)

we just did this.

  1. Close all browser windows and open a new private/incognito browser window to access your dvr (Some users had to access the DVR web UI remotely or using secure HTTPS to add a source)

have tried incognito. still the same 401 error.

  1. Open a second tab in the same browser window and login to , dismiss any popups/notifications your provider may display on login.
  1. If adding a TVE source, click and HOLD the Login button.

have tried this. no luck.

  1. Before rescanning individual channels, and before removing a source to re-add, use Update Password under the gear dropdown next to your source in the DVR web UI and just key in your existing Provider password to clear the chromedata folder (likely used with other providers, but known to be used for Spectrum and Xfinity per this post )
  2. Individually rescan channels with issues using Rescan Channels under the gear dropdown next to your source in the DVR web UI.

i can't do this because i can't get it to even add the provider.

  1. Reboot your server or restart your package or container if running in one.

have tried this (both server and container). no luck.

  1. Remove and re-add your source, then individually rescan any channels with issues.

obviously this isn't working.

and then

yeah, i'll submit it now...but i would love to know why a server / product that had been bulletproof for so long now all of a sudden has so many issues.

Since installing the new tve container, right?
(I've learned not to assume anything :wink:

actually, no. i'll try again.

as expected, no change. still the same 401 error.

Logs have been submitted as 4194a6ae-3100-4cff-83bb-7dcfa05e5795 .

It's a cat/mouse game with the networks and auth servers. I went for a week where I couldn't add Xfinity on multiple servers.

that's fair, but it's not worth it for me to pay $80/yr for this to record TVE when i can just pay DTVS $10/mo for unlimited DVR and at least i know that'll always work (for the most part).

when it just worked without me having to continually monitor it, it was worth the $80/yr...but if i'm going to have to jump through hoops all the time, i'm not sure. as it stands right now, i'm unable to get ANY value out of the software.

Yah, I understand the frustration.
I don't rely on TVE as I know it's Beta, it and streaming are not 100% reliable and I have an HDHR Prime. I only use a few TVE channels because they're in HD and my Xfinity sub has them in SD via my HDHR Prime.
But I was still frustrated when I couldn't add Xfinity TVE for a week, just because it should have worked.

it's more the frustration of having something that worked so well for so long just suddenly stop working without any indication as to why. if i were earlier on in my yearly subscription rather than being due for renewal next month, i'd be super pissed having paid for a year of something i can't even use.

i know it's technically beta, but i literally never had a single issue with it until recently. that's where the real frustration lies. originally (back when locast was a thing) i actually barely even touched my DTVS sub, because channels w/ locast integrated and TVE for the cable channels just always worked, and all the recordings were local for we're at the point unfortunately where i may have to ditch it and use DTVS exclusively. i would hate to give them more money, but i may not have a choice.

Just curious since you didn't mention it.
Which Providers did you try adding back since you updated the container image and Channels DVR to latest pre-release. Did they all fail to add?

i've only been trying DTVS since that was always the easiest. i haven't even attempted xfinity...granted it might not be safe to assume that it won't work, but that has always been the biggest PITA of the three.

honestly i'm afraid to remove anything now since i can't get DTVS to re-add after removing it.

Can you try turning off your network ad blocker and see if that helps your situation?

no change.

Does the tve error screenshot lend any useful info?http://server.ip:8089/providers/tve/error_screenshot.png