TVE Troubleshooting tips

Troubleshooting steps to follow, like a checklist

  • If you can't watch the network at their Live streaming website, nothing Channels can do. Like nbc.com/live or check availability buttons at Channels Support - TV Everywhere Availability for your Provider
  • Make sure your package or container (if running in one) is up to date.
  • Update to the latest DVR prerelease version see this article for how
  • Run troubleshooting from the DVR web UI Support>Troubleshooting and make sure all green checkmarks. (If it says Chrome corrupted or not up to date it should offer a green fix button to press.)
  • Make sure your chrome or headless chrome is up to date. (Current included version is 89.0.4389)
  • Close all browser windows and open a new private/incognito browser window to access your dvr (Some users had to access the DVR web UI remotely or using secure HTTPS to add a source)
  • Open a second tab in the same browser window and login to nbc.com/live, dismiss any popups/notifications your provider may display on login.
  • If adding a TVE source, click and HOLD the Login button.
  • Before rescanning individual channels, use Update Password under the gear dropdown next to your source in the DVR web UI and just key in your existing Provider password to clear the chromedata folder (which is only used for Spectrum and Xfinity per this post)
  • Individually rescan channels with issues using Rescan Channels under the gear dropdown next to your source in the DVR web UI.
  • Reboot your server or restart your package or container if running in one.
  • Remove and re-add your source, then individually rescan any channels with issues.

If all the above fails, submit DVR diagnostics from the DVR web UI Support>Troubleshooting.

More tips in the following posts

5 Likes

Some other tips.

  • If running in a container, use the TVE container Docker Hub
  • Using a VPN or geo-location blocker is not supported. Disable these temporarily when adding a TVE source or scanning channels.
  • Use a secondary provider account with 2FA/MFA/Recovery options disabled.
  • If using Xfinity as a provider, turn off auto-authentication on the Primary user account at https://idm.xfinity.com/myaccount/userprofile (login there with your Primary user account id/name) see next post for more info

Xfinity auto-auth setting

Listed as a Note in the first post of this topic Provider - Xfinity that it needs to be done If you have separate Xfinity logins for TV and Internet. I only have one login for both and turning it off worked for me.