Local Fox Suddenly Missing, Timeouts

A week or two ago I suddenly lost my local Fox (WNYW) on 6002. When I look at the logs I see this:

[TVE] action=navigate url=https://www.foxsports.com/live
[TVE] action=click_interstitial
[TVE] action=fox_station err=context deadline exceeded

Strangely I do get Fox News, For Business News, and FS1 and FS2. Going to foxsports.com/live and logging in with TV provider credentials works.

I sent a diagnostic log via email last week but I have not heard back, so hoping someone here could help.
Original Diagnostic: fe7889ec-3c3f-4072-ae76-8a8c2ca67cd8

Good luck. I gave up trying 11 days ago. Couple other users also.

1 Like

Same here. When I try to rescan the TVE channels it just comes back saying zero new channels to scan. Everything else that is TVE works fine but for some reason FOX never even shows up.

I have posted about it and submitted logs via email but no response of any kind. I assume they don't have a solution yet because the devs are usually on top of these things to sort it out.

Luckily I have OTA for the locals. If it were an issue with the cable only channels then it would be more of an issue for me.

Just updated to prerelease 2022.11.09.1733 and got Local Fox to authorize this time.

Unfortunately didn't work for me. Although, now I have a question- Is the need to install the Chrome browser only for the authorization process or playback as well?

Mine may even be a different issue:

2022/11/09 16:29:05.068342 [TVE] Channel scan starting for 0 channels on Spectrum
2022/11/09 16:29:05.068374 [TVE] Channel scan finished after 0s: 0/0 channels available

Yes it needs Chrome.
If your install doesn't inlude it, you need to install the latest Chrome browser (like on Windows).
If you run the DVR troubleshooting it should tell you
From the Knowledge Article About TV Everywhere

Technical overview
The DVR software connects to network streams using a background (headless) Chrome browser controlled by the DVR
During the channel scan, the DVR will navigate the Chrome instance to each network website and enter your cable login to see if it works

The issue I have is that Chrome is installed but won't start up. It complains about x server not starting. It is installed (and xvfb) but I can't get them to start.
I have Googled the issue but none of the recommended solutions have worked for me.

I had that problem running Channels DVR TVE in a docker container all the time.

I gave up using docker for Channels DVR TVE

I have heard about that one too. I don't run in docker or use docker at all.

I am doing some more research now since you reminded me that I was having this issue. I hope I can find something that will work.

What are you running Channels DVR Server on?

I have the Beelink Mini S Intel 11th Gen 4-Cores N5095 device with Ubuntu Server on there.

Everything was working fine at some point because I was able to get all the TVE channels to be scanned and working when I first set everything up, Although FOX never was scanned properly. It works via the website directly though so I know it's available to me from my Spectrum account.

1 Like

I had to remove snapd ....

I did that too. I then installed Google Chrome directly. It's installed, it just won't start because of this error:

[1847:1847:1109/165448.265060:ERROR:ozone_platform_x11.cc(239)] Missing X server or $DISPLAY
[1847:1847:1109/165448.266264:ERROR:env.cc(255)] The platform failed to initialize. Exiting.

However, I do have that installed, it just acts like it's not there.

1 Like

I think i uninstalled Chromium after and then re-installed via directions on the channels docs.

1 Like

yeah, installing the latest pre-release did not work for me either unfortunately. It doesn't even seem to try scan for local Fox channel. I am now getting a failed: context deadline exceeded for BTN and Desportes

1 Like

I am not sure when it happened, but I noticed today that the TVE version of my local FOX channel is now there. I didn't manually scan it, just noticed it randomly. I have been updating to each beta DVR update, so something changed.

1 Like

Updating to latest pre-release did not work for me unfortunately.

1 Like

Still no resolution for me on this. Anyone else still having trouble with local fox?


You can try the new prerelease

1 Like

I just lost FOX using TVE.....I am running 2023.01.11.0120

I checked my logs and around 1/1 I was watching FOX without error....