Provider - YouTube TV

I actually already did that. The NBC app and the YouTube TV app both work on my phone.

You may just need to wait a bit and try again then. Is it a new google account or new yttv sub?

The google account is not new but I just got YouTube TV a few days ago. Just tried it again

I am trying Hulu as well. I don't really care which one works I just need one or the other.

I dont even have NBC as an option for YouTube TV anymore. It has worked fine but recently disappered. I can login to NBC.com with my Youtube TV credentials and works fine.

I also have HULU and it is still there and logged in, so not sure what happened.

I take it back. Just found another post that tells you to uncheck locals at the bottom of settings page and then recheck. That fixed the problem and NBC is back on YoutubeTV.

Unable to link Youtube TV Everywhere in Channels.

I have been able to do this in the past. After I started with Channels (Feb 2022) I then signed up for YouTube TV and then was able to successfully link Youtube TV Everywhere in Channels (after first doing "link provider" at https://nbc.com/live )

Then I unsubscribed from YTTV. Resubscribed just now to YTTV, using the same google account as before. That account does not have 2FA. But now, authentication is failing:

Have done all of the following:

  • Link provider at https://nbc.com/live. That works succesfully and at NBC webpage I can watch channels that are provided via YTTV (eg Bravo).

  • A few times: At https://nbc.com/live, unlink provider, clear browser cache, relink YTTV as provider.

  • Updated Channels to latest prerelease.

  • Restarted Channels DVR.

  • Logged into YTTV on the app on my phone. YTTV works there.

  • Tried using Chrome browser instead of Safari for all steps

Those are most of the steps I saw above in this thread (and also in other threads such as Youtube TV Everywhere no longer working - #2 by chDVRuser and

I haven't tried creating a new account. Is that the next thing to try? And if I do, how would I link the new account to the YTTV subscription that I just resubscribed to under the old Google account?

Any help appreciated! I re-signed with YTTV only to watch Wimbledon. And I hate using the YTTV DVR, so really was counting on using the Channels DVR via TVE to record content.

UPDATE: I tried the only other option that I've identified -- creating a new Google account. However, apparently google accounts now cannot be created without providing a mobile number, which I am not willing to do. So, creating a new google account turns out not to be an option for me.

Any other possibilities at all to get YTTV TVE authenticated..?

Maybe someone who had the same issue will reply.

I don't use YTTV, but reading through the topic since last summer, it appears some got it working by running it in a docker container or a linux install instead of Windows. Are you using Windows?

Another thought is try to access the DVR web UI using SECURE HTTPS when you add the YTTV source while at the same streaming from nbc/live in another tab of the same browser. Strange as it may sound it helped me with some Xfinity channels that wouldn't auth. I always do this in a private/incognito browser window.

1 Like

All the stuff I talked about had to do with not having 2fa prior. I also had another account created just to use that as the TVE. Now that they have moved everything over to 2fa and changed how it all works. Seems to be more of a pain now than what it is worth. You could try creating a second account with the mobile number. Then once created see if you can remove the number after the fact. Its really all I can offer you at this point. Or look else where from youtube. Security is a great thing until it breaks the thing you want to do.

2 Likes

@chDVRuser and @jxxaxxy -- thanks so much for taking the time and effort to reply. Much appreciated.

@chDVRuser -- Right, I am using Windows. Thanks for the tip about it possibly working with docker and/or Linux. I actually do have a linux server that can run docker containers, but for me moving Channels DVR to that is feeling like more trouble than it's worth. (Especially given that I only plan to have my YTTV subscription for one month).

Thanks also for the suggestion about authenticating in a browser tab while simultaneously playing something at NBC in another tab. I had actually already tried that (although not with private/incognito windows) but that didn't work for me. After your suggestion I tried in private windows, but I was unable to access my Channels DVR via https:// -- my server only seems to support http:// [Is there a configuration somewhere in settings for https..? Does it require remote access to be enabled? -- which I haven't done].

@jxxaxxy -- I agree, it has become more trouble than it's worth. (And I would suspect Google of pushing 2FA via mobile phone not only for security --but also for better data mining :wink:

Time to look into Hulu + Live, I think, at least for when I next sign up for a cable replacement after I cancel YTTV at the end of the month. Not sure why I never considered Hulu before. I was just checking, and it seems to have as good TVE coverage as YTTV. Also, with its Disney+ and ESPN+ bundle, it seems (for my family) like a better value.

Thanks again, all!

1 Like

I have Hulu + Live currently. So far it has been very good. Not very many complaints here at all. Having Disney+ with it is nice too. Specially all the star wars spin offs gets me something to watch that I probably wouldn't have. I could live without the ESPN+. I installed the app and probably logged onto it once haha.

You may get a certificate warning since your dvr server doesn't have a certificate for direct local lan access, so just ignore it and continue.
Here's what I see in Firefox.
I click Advanced, then Accept the Risk and Continue


Brave and Edge about the same

@jxxaxxy -- thanks. Good to know about the good experience with Hulu. I'm seriously considering trying it, even though I usually live without cable channels and only subscribe to a cable streaming service occasionally for a month when there's something I want to follow (eg Olympics). Having looked into it now I'm again puzzled that I missed seeing how much it offers.

@chDVRuser -- thanks much for this info. That is what I had tried yesterday (I use Firefox as well, but also tried with Safari and maybe Chrome). I did the "accept the risk" thing but then it just hung. I suppose it could be because I run NoScript and Ghostery in Firefox and block lots of stuff.

UPDATE: just tried it again from another computer, and this time the https access worked. Didn't enable TVE authentication, though. But that's OK, I've given up on YTTV -- Hulu + Live will be it going forward.

Thanks again for all the help!

1 Like

Reading though all the posts I could find I still can't get an answer as to why I lost Discovery and other channels on YTTV using TVE. I'm running DVR version 2022.06.30.0107 on a Synology. I can login and authorize YTTV at https://go.discovery.com/channel/discovery in an incognito browser window and play live video. When I try to rescan the Discovery channel in another private tab the authorization fails. Here is the log file for at rescan attempt:

2022/07/05 15:52:08.920008 [TVE] action=version product=Chrome/89.0.4389.114 jsVersion=8.9.255.24 protocol=1.3 [email protected]
2022/07/05 15:52:08.921033 [TVE] action=mock
2022/07/05 15:52:08.929740 [TVE] action=navigate url=https://auth.sciencechannel.com/login-affiliates?returnUrl=https://www.sciencechannel.com/live-now&hostUrl=us1-prod-direct.sciencechannel.com
2022/07/05 15:52:08.930865 [TVE] action=request type=Document method=GET url=https://auth.sciencechannel.com/login-affiliates
2022/07/05 15:52:08.930905 [TVE] action=auth_domain domain=auth.sciencechannel.com
2022/07/05 15:52:08.930913 [TVE] action=scienceauth reason=login
2022/07/05 15:52:09.306631 [TVE] action=wait_for_page
2022/07/05 15:52:14.755401 [TVE] action=page_ready
2022/07/05 15:52:14.755465 [TVE] action=wait_for_page done=true reason=page_ready
2022/07/05 15:52:16.756490 [TVE] action=click_interstitial
2022/07/05 15:52:16.758805 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2022/07/05 15:52:16.775679 [TVE] action=wait_for_interstitial
2022/07/05 15:52:18.641512 [TVE] action=request type=Document method=GET url=https://api.auth.adobe.com/api/v1/authenticate
2022/07/05 15:52:18.695981 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/api/v1/authenticate
2022/07/05 15:52:18.877669 [TVE] action=request type=Document method=POST url=https://youtube.auth-gateway.net/saml/saml2/idp/SSOService.php
2022/07/05 15:52:19.114698 [TVE] action=request type=Document method=GET url=https://youtube.auth-gateway.net/saml/module.php/authbypass/firstbookend.php
2022/07/05 15:52:19.214979 [TVE] action=request type=Document method=GET url=https://youtube.auth-gateway.net/saml/module.php/authbypass/firstbookend.php
2022/07/05 15:52:19.305706 [TVE] action=request type=Document method=GET url=https://accounts.google.com/o/oauth2/auth
2022/07/05 15:52:25.356008 [TVE] action=page_ready
2022/07/05 15:52:25.356058 [TVE] action=wait_for_interstitial done=true reason=page_ready
2022/07/05 15:52:25.356081 [TVE] action=fill_form [email protected]
2022/07/05 15:52:25.358719 [TVE] action=tvejs msg="googleLogin"
2022/07/05 15:52:25.390522 [TVE] action=wait_for_auth
2022/07/05 15:52:27.884335 [TVE] action=tvejs msg="googleLoginPassword browser or app may not be secure"
2022/07/05 15:52:49.391306 [TVE] action=auth_timed_out
2022/07/05 15:52:49.391369 [TVE] action=screenshot
2022/07/05 15:52:49.460053 [TVE] action=screenshot size=27998
2022/07/05 15:52:49.460284 [TVE] action=capture_html
2022/07/05 15:52:49.639062 [TVE] action=capture_html size=1900715

Apparently it is having a problem with "googleLoginPassword browser or app may not be secure". Any ideas on how to get around this?

--Chris

I'm having the exact same problem, however, I decided to try removing the TVE source and add it back, and can't get it to add. I've tried the account I have been using, as well as created a brand new google account. The new account gets the same error now, but was getting prompted for the captcha. I am not using a VPN, so not sure why that was happening.

Please try with v2022.07.05.1953 or later

I upgraded to this version this afternoon. But cannot get HGTV to authorize with a youtube ID on Win 10 pro after the upgrade. It does work on HGTV website (logging in with youtube tv) and it does work on Channels with a Direct TV login.

This is still giving me the browser or app is insecure. Running 2022.07.05.2313

Could this be related? I know it has been a month, but just noticed this:

I had this happen yesterday. Started losing channels and not able to re-authenticate them. The only thing that finally worked was these steps

  1. Remove YTTV as a source
  2. Create another Google account
  3. Add the new google account to my YTTV family group.
  4. Open NBC.com in Chrome on the machine running Channels and log in with YTTV credentials. Stream a live source.
  5. Open Channels in a private tab on the same instance of Chrome.
  6. Add YTTV back as a TVE source.