Provider - YouTube TV

I am running Channels DVR server on a Synology 920+ NAS running DSM 6.2.4. I have not updated to DSM 7, and I don't plan to do that anytime soon, if ever.

A week or two ago, after Channels quit recording anything, I updated Channels' Chrome from 76.x to 89.x by

  1. Clicking "Add source"

  2. Choosing a provider I don't have

  3. Entering test/test for username/password

  4. Clicking and holding the SIgn In button

And that fixed Channels for awhile.

Channels stopped recording NBC, and when attempting to get it working again, I found I was getting the "context canceled" error. I updated the DVR server to 2021.08.19.2122, made sure I was using a Gmail account without 2FA enabled, and logged into https://www.nbc.com/live first. I started over with Channels DVR Server's source, so Settings now says "No sources found". When I chose "Add Source", "TV Everywhere", put in the provider, login and password, then click and hold the "Sign In" button, I got the "context canceled" error, with this in the log:

(Edit: redacted all but the last line, the full logs were emailed to support)

2021/08/20 01:54:18.608728 [TVE] Auth failed for YouTubeTV: context canceled

Next, in this thread on Channels support forums:

I saw this:

I created an NBCUniversal profile, and added logging into it into the list of things to do, which is now:

  1. sign in to a Gmail email account with YouTubeTV subscription and without 2FA enabled

  2. sign in to www.nbc.com/live, linking it to YouTubeTV as provider

3, sign in to NBCUniversal profile

  1. choose "Add Source" in Channels DVR server Settings

  2. choose YouTubeTV as TV Provider, enter Gmail login and password, click and hold Sign In button

Then, I got different behavior: the error is now "Cable Provider Authentication Failed". The log for that error is:
(Edit: redacted all but the last few lines, the full logs were emailed to support)

.872888 [TVE] action=wait_for_auth

2021/08/20 02:15:55.371351 [TVE] action=tvejs msg="googleLoginPassword browser or app may not be secure"

2021/08/20 02:16:16.873473 [TVE] action=auth_timed_out

2021/08/20 02:16:16.873564 [TVE] action=screenshot

2021/08/20 02:16:16.943787 [TVE] action=screenshot size=26460

2021/08/20 02:16:16.943981 [TVE] action=capture_html

2021/08/20 02:16:17.083688 [TVE] action=capture_html size=1858083

2021/08/20 02:16:17.101169 [TVE] Auth failed for YouTubeTV: Cable provider authentication failed

The screenshot that Channels displayed reads:

(data entry field that says "Sign In With Google")

Couldn't sign you in

This browser or app may not be secure

Try using a different browser. If you're already using a

supported browser, you can try again to sign in.

(button saying "Try again")

I tried updating Channels' Chrome again, but it seems there are no new Chrome updates.

At this point, clicking the "Sign In" button without holding it down gets me the "Context canceled" error, while clicking and holding the "Sign In" button gets me the "Cable provider authentication failed" error. My Channels DVR Server has no sources to record from so it’s totally broken now.

I have gone to the Channels DVR Server Support Troubleshooting window, where all six items have green checkmarks, and submitted diagnostics logs along with an email to tech support with a copy of this post.

Edit: removed parts of logs that don't need to be in this post

Last official responses from the devs are above in this thread


I can only think YTTV=Google and Chrome=Google

I can confirm that running Channels on Docker is the solution to not being able to authenticate with YouTubeTV. chDVRuser posted a great writeup about how to do that on Synology here:

I’m holding out hope that once @tmm1 gets his hands on his own Synology that he’ll be able to get it working (as well as DIY and Science) with the native package. I don’t like adding complexity unless I have to.

1 Like

With Locast gone, YouTube seemed to be the best option for us. Of course, we are having the same authentication issues with Channels. I followed all of the instructions. @tmm1 are you actively looking to resolve this or should I look for a different solution???

2 Likes

Whatever is happening is due to something Google is doing explicitly, and is not something we can work around. They own both Chrome and YTTV, and have put code in both places to prevent things from working correctly.

Thanks Aman. FWIW I saw someone earlier in the thread said they were able to authenticate with a brand new account. I tried that as well and it worked.

1 Like

I am running Channels DVR Server on a Raspberry Pi 4 that boots from an external hard drive. When I installed Channels DVR Server as per the instructions at https://getchannels.com/dvr-server/#rpi4, the authentication for my YouTube TV account always failed. However, when I installed Raspberry Pi OS on the boot drive and then installed Channels DVR server as per the instructions at https://getchannels.com/dvr-server/#linux, I had no problem authenticating the same YouTube TV account. Hope this helps.

Wild guess - the chrome ver on the dedicated build (rpi4 URL) is probably older, by default. The linux url instructions have you pull latest ver as part of the installation.

If I'm right, you can upgrade the dedicated build chrome build by enabling ssh on the pi and running:

curl -XPOST http://x.x.x.x:8089/providers/tve/chrome

This should work, if I'm right.

Out of desperation I just created another new account and it worked - this is insane.

1 Like

I think Google is using some kind of AI to decide what accounts are high risk and what it thinks are hacking attempts. There's no clear logic to it. With new accounts there's no history so it doesn't have enough information to decide to block you.

Then why does the same account that gets blocked on Windows work in Docker?

Presumably malware that its trying to protect against is more prevalent on Windows, and running in docker makes it appear like linux instead?

Windows 10 Pro.

I was trying to get my google account working, no dice. I'm the primary account but don't have 2FA on. At any rate tried my hubbies account and it wouldn't work either.

I had to delete one of my kids accounts from Family, then made myself a brand spanking new google account and tried that ... instant success scanning channels etc.

I don't think my kid will be happy to find he's deleted from my Family (ouch!)

1 Like

I run 2 channels dvr servers in lxc containers (ubuntu:20.04) and I was getting blocked as well by YTTV. I created a Docker version and was able to login.

Instead of using Chrome to capture the stream, would it be possible to use a different browser for YoutubeTV?

It must be the account. I have failed to get it to work for a month on Windows 11 Pro, Mac and Raspberry Pi. Created a new clean Gmail/YTTV account and it worked immediately on Windows, Mac and Pi server. Also spoke to a friend that had the same issue on a Windows server, he was able to login with a fresh account as well on Windows. Glad to have it back in action in time for the football!

Never was able to get Docker installed properly so cannot confirm anything with Docker.

2 Likes

I’ve tried everything and can’t seem to get logged in. I keep getting this error:

I tried my primary google account and then created a family group and added a shared family account with pretty much all security disabled and still couldn’t log in. I tried safari browser on my iPhone, Chrome browser on MacBook, and Safari browser on MacBook.

Any suggestions?

1 Like

I'm trying to get local NBC (WVLA here in Baton Rouge, LA) via TVE/YTTV with no success so far. I can login into NBC LIve and watch live shows, and the guide there shows programming round the clock.

Unfortunately, I did not see the suggestion to login to NBC live online before I set up my DVR server.

When I manage LIneup on the YTTV source, I don't see the NBC channel even after Rescanning Channels (unless I just am not seeing it). Looking at the log, I don't even see that it scanned for an NBC channel (well, there were MSNBC, CNBC, NBCSN, 8 regional NBCSN channels, and NBCNEWS).

What should I try next?

Submit diagnostics and email support